IT Express phone number 530-754-4357 Outage
Incident Report for UC Davis
Resolved
Phone service to IT Express at 530-754-4357 has been restored.
Posted Jun 20, 2017 - 10:49 PDT
Investigating
The IT Express phone line 530-754-4357 is currently experiencing an outage. Staff are investigating the issue. If you need assistance please email ithelp@ucdavis.edu.

----------------------------
IT Express Service Desk
ithelp@ucdavis.edu
530.754.HELP (4357)
Posted Jun 20, 2017 - 07:40 PDT
This incident affected: Voice Telephone System.